We have implemented a fix and are monitoring closely. The issue was a temporary spike in backend communication with external services and slow responses. This led to slow responses in our system.
Posted Nov 17, 2023 - 13:38 CET
Identified
The issue has been identified and we work to document the root cause.
Posted Nov 17, 2023 - 13:13 CET
Investigating
We are currently investigating the downgraded platform performance of our dashboard.